Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-20-2017 12:22 AM
Hi. i'm trying to install Ranger KMS on HDP 2.4 (Non-Kerberized cluster), and running into issues.
The error i get is shown below (not able to connect to SQL Server using 'root' user)
Any ideas on this ?
resource_management.core.exceptions.Fail: Execution of 'python /usr/hdp/current/ranger-kms/dba_script.py -q' returned 1. 2017-01-20 00:06:01,280 [I] Running DBA setup script. QuiteMode:True 2017-01-20 00:06:01,280 [I] Using Java:/usr/lib/jvm/java/bin/java 2017-01-20 00:06:01,280 [I] DB FLAVOR:MYSQL 2017-01-20 00:06:01,288 [I] DB Host:sandbox.hortonworks.com 2017-01-20 00:06:01,294 [I] ---------- Verifing DB root password ---------- 2017-01-20 00:06:01,296 [I] DBA root user password validated 2017-01-20 00:06:01,299 [I] ---------- Verifing Ranger KMS db user password ---------- 2017-01-20 00:06:01,299 [I] KMS user password validated 2017-01-20 00:06:01,301 [I] ---------- Creating Ranger KMS db user ---------- 2017-01-20 00:06:01,302 [JISQL] /usr/lib/jvm/java/bin/java -cp /usr/share/java/mysql-connector-java.jar:/usr/hdp/current/ranger-kms/jisql/lib/* org.apache.util.sql.Jisql -driver mysqlconj -cstring jdbc:mysql://sandbox.hortonworks.com/mysql -u root -p '********' -noheader -trim -c \; -query "SELECT version();" SQLException : SQL state: 28000 java.sql.SQLException: Access denied for user 'root'@'sandbox.hortonworks.com' (using password: YES) ErrorCode: 1045 2017-01-20 00:06:02,196 [E] Can't establish db connection.. Exiting..
Created 01-20-2017 12:28 AM
Looks like root user does not have access from remote host. Please update root user to allow remote access
Created 01-20-2017 12:28 AM
Looks like root user does not have access from remote host. Please update root user to allow remote access
Created 01-20-2017 12:30 AM
@Karan AlangI mean to say that , at Mysql side change the user access permissions to connect from remote host. You can follow http://benrobb.com/2007/01/15/howto-remote-root-access-to-mysql/ to do that.
Created 01-20-2017 01:31 AM
@apappu - thanks, i was able to make this work.
Another question - per my understanding, i'll be able to install & use Ranger KMS in a non-Kerberized environment also.
Can you pls. confirm.
Thanks!
Created 01-20-2017 01:33 AM
Yes, you can do that.