Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Ranger fails with error "Error creating policy"

avatar
Expert Contributor

I am trying to create a new policy in Ranger. When you click on Add, 'Error creating policy' is shown.

captura.jpg

This is what /var/log/ranger/admin/xa_portal.log shows:
2017-10-24 15:51:28,710 [http-bio-6080-exec-12] INFO  org.apache.ranger.common.RESTErrorUtil (RESTErrorUtil.java:345) - Request failed. loginId=holger_gov, logMessage=User 'holger_gov' does not have delegated-admin privilege on given resourcesjavax.ws.rs.WebApplicationException  at org.apache.ranger.common.RESTErrorUtil.createRESTException(RESTErrorUtil.java:337)

Connection test to Ranger Admin DB runs ok (jdbc:postgresql://localhost:5432/ranger).

This is a 2.6.1 sandbox based environment. What can be causing this issue?

1 ACCEPTED SOLUTION

avatar

User holger_gov does not have privileges to create policy. User has to have ADMIN role in ranger or needs to be delegated admin for the specified resource. Can you check this?

See https://community.hortonworks.com/content/kbentry/88202/apache-ranger-delegated-admin.html for delegated admin feature.

Also, ranger version in HDP 2.6.1 should be ranger 0.7.

View solution in original post

1 REPLY 1

avatar

User holger_gov does not have privileges to create policy. User has to have ADMIN role in ranger or needs to be delegated admin for the specified resource. Can you check this?

See https://community.hortonworks.com/content/kbentry/88202/apache-ranger-delegated-admin.html for delegated admin feature.

Also, ranger version in HDP 2.6.1 should be ranger 0.7.