Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Ranger test db connection failing

avatar
Super Collaborator

I am getting this error

2017-07-11 13:18:41,662 - Check db_connection_check was unsuccessful. Exit code: 1. Message: ERROR: Unable to connect to the DB. Please check DB connection properties.
java.sql.SQLException: Access denied for user 'root'@'hadoop1.tolls.dot.state.fl.us' (using password: YES)

ok I fixed this issue by creating the user 'root'@'hadoop1.tolls.dot.state.fl.us' but my question is why ranger is connecting to the database as root1@hadoop1 and not root@hadoop2 ?

1 ACCEPTED SOLUTION

avatar

what version of HDP are you using? Make sure you have given all privileges to the root user "with grant option". Please see https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.1/bk_security/content/configuring_mysql_for_r...

View solution in original post

2 REPLIES 2

avatar

what version of HDP are you using? Make sure you have given all privileges to the root user "with grant option". Please see https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.1/bk_security/content/configuring_mysql_for_r...

avatar

where is ranger running? If it is on 'hadoop1', then it is connecting to db from 'hadoop1'. You could also create 'root'@'%' user.