Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-11-2017 05:24 PM
I am getting this error
2017-07-11 13:18:41,662 - Check db_connection_check was unsuccessful. Exit code: 1. Message: ERROR: Unable to connect to the DB. Please check DB connection properties. java.sql.SQLException: Access denied for user 'root'@'hadoop1.tolls.dot.state.fl.us' (using password: YES)
ok I fixed this issue by creating the user 'root'@'hadoop1.tolls.dot.state.fl.us' but my question is why ranger is connecting to the database as root1@hadoop1 and not root@hadoop2 ?
Created 07-11-2017 05:38 PM
what version of HDP are you using? Make sure you have given all privileges to the root user "with grant option". Please see https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.1/bk_security/content/configuring_mysql_for_r...
Created 07-11-2017 05:38 PM
what version of HDP are you using? Make sure you have given all privileges to the root user "with grant option". Please see https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.1/bk_security/content/configuring_mysql_for_r...
Created 07-11-2017 05:39 PM
where is ranger running? If it is on 'hadoop1', then it is connecting to db from 'hadoop1'. You could also create 'root'@'%' user.