Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 12-10-2015 10:43 AM - edited 08-19-2019 05:39 AM
Hi I am using the Sandbox 2.3.2
I just download it 2 weeks ago.
At the first week before I am running with 4 GB RAM. Then i request it to my team to upgrade memory to 8 GB.
But the Resource Manager YARN and Ambari Server Alert cannot be started. always CRIT
Please what do i miss ?
Thank you
yan
Created on 12-14-2015 09:14 AM - edited 08-19-2019 05:39 AM
@yan Adiputra Just looking at your logs, looks like the problem is a wrong memory configuration:
2015-12-10 09:57:39,443 INFO service.AbstractService (AbstractService.java:noteFailure(272)) - Service RMActiveServices failed in state INITED; cause: org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min. org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min. at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.validateConf(CapacityScheduler.java:179) at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.initScheduler(CapacityScheduler.java:308) at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.serviceInit(CapacityScheduler.java:348) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) at org.apache.hadoop.service.CompositeService.serviceInit(CompositeService.java:107) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager$RMActiveServices.serviceInit(ResourceManager.java:572) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.createAndInitActiveServices(ResourceManager.java:972) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.serviceInit(ResourceManager.java:259) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.main(ResourceManager.java:1202)
According to the logs the following config is set:
This config is impossible min has to be smaller than max
Could you please switch the configurations, so that you have:
Created 12-10-2015 11:37 AM
Click Dashboard --> Yarn and then paste the screen shot here.
cd /var/log/hadoop-yarn and check for log files
paste resource manager entries (errors if there are any)
Created on 12-14-2015 07:18 AM - edited 08-19-2019 05:39 AM
Thank You For the Answer
Here the screen shoot
and about the error there is some
2015-10-27 15:21:36,887 ERROR resourcemanager.ResourceManager (LogAdapter.java:error(69)) - RECEIVED SIGNAL 15: SIGTERM
2015-10-27 15:21:37,077 ERROR resourcemanager.ResourceManager (ResourceManager.java:run(691)) - Returning, interrupted : java.lang.InterruptedException
here the full log :
https://drive.google.com/open?id=0ByY5H-XcydgiNjRJNVliNFh6NW8
Created 12-14-2015 07:53 AM
Could not access the log. Maybe post it to http://pastebin.com or https://gist.github.com?
Created 12-16-2015 06:28 AM
here the file if you wanted
i cannot upload to pastebin because the file is 44 MB
https://www.dropbox.com/s/c70jir1v6re29ex/yarn-yarn-resourcemanager-sandbox.hortonworks.com.zip?dl=0
Created 12-10-2015 09:51 PM
Hi @yan Adiputra, can you give the VM runs best with 8GB allocated to it. If you have 8GB total for your machine, try giving the VM about 6GB.
Created 12-14-2015 07:48 AM
Could you please check if the RM is not still running? (process list, ps aux | grep resourcemanager)
Also make sure there is no pid-file in /var/run/hadoop-yarn/yarn/
Created on 12-14-2015 09:14 AM - edited 08-19-2019 05:39 AM
@yan Adiputra Just looking at your logs, looks like the problem is a wrong memory configuration:
2015-12-10 09:57:39,443 INFO service.AbstractService (AbstractService.java:noteFailure(272)) - Service RMActiveServices failed in state INITED; cause: org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min. org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min. at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.validateConf(CapacityScheduler.java:179) at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.initScheduler(CapacityScheduler.java:308) at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.serviceInit(CapacityScheduler.java:348) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) at org.apache.hadoop.service.CompositeService.serviceInit(CompositeService.java:107) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager$RMActiveServices.serviceInit(ResourceManager.java:572) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.createAndInitActiveServices(ResourceManager.java:972) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.serviceInit(ResourceManager.java:259) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.main(ResourceManager.java:1202)
According to the logs the following config is set:
This config is impossible min has to be smaller than max
Could you please switch the configurations, so that you have:
Created 12-14-2015 09:36 AM
Thank You very much. i don't know Hadoop original setting must be check first.
Created 12-14-2015 09:39 AM
Glad I could help. Usually these settings are correct in our sandbox and you dont have to reconfigure them after you boot the sandbox. I'll let our sandbox-team know, so they can check if there might be an issue.