Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-19-2016 03:29 PM
While connecting to an ORACLE database with --direct option, gives error
sqoop import --options-file db.config --table table1 --direct -m 4
ORA-00942: table or view does not exist
Same sqoop command works fine without --direct option.
sqoop import --options-file db.config --table table1 -m 4
Created 02-19-2016 03:31 PM
userid that is used to login to ORACLE should have SELECT_CATALOG_ROLE to use --direct option.
Created 02-19-2016 03:30 PM
it's Oracle related http://www.techonthenet.com/oracle/errors/ora00942.php
Created 04-26-2016 04:46 PM
mapreduce-import-failed.txtHi,
I am getting sqoop import error using oracle tables:
sqoop error tool.importtool error during import import job failed
Can you please advise. I have attached the log for your reference. Thank you.
Created 02-19-2016 03:31 PM
userid that is used to login to ORACLE should have SELECT_CATALOG_ROLE to use --direct option.
Created 02-19-2016 03:41 PM
I have accepted this as solution
Created 02-20-2016 08:32 PM
Thanks Neeraj.
Created 02-19-2016 03:33 PM
Table does not exist in oracle database .
Make sure the case sensitivity too in case table exists
Created 02-19-2016 03:35 PM
Created 04-26-2016 04:47 PM
Hi,
I am getting sqoop import error using oracle tables:
sqoop error tool.importtool error during import import job failed
Can you please advise. I have attached the log for your reference. Thank you.mapreduce-import-failed.txt
Created 02-19-2016 03:36 PM
@Neeraj Sabharwal @Artem Ervits Table exists in ORACLE database and user had access to table because I was able to use same sqoop command without --direct option. It had to do with SELECT_CATALOG_ROLE not granted to user. --direct option requires access to ORACLE catalog tables in addition to actual table.