Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 07-29-2016 10:11 PM - edited 08-18-2019 05:16 AM
In my HDP 2.3.2 Sandbox with no authorization for HiveServer2, I'm attempting to enable http mode, but connections are being "refused". See error thrown by beeline.
[root@sandbox ~]# beeline -u jdbc:hive2://sandbox.hortonworks.com:10001/default;transportMode=http;httpPath=cliservice
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/usr/hdp/2.3.2.0-2950/spark/lib/spark-assembly-1.4.1.2.3.2.0-2950-hadoop2.7.1.2.3.2.0-2950.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/usr/hdp/2.3.2.0-2950/hadoop/lib/slf4j-log4j12-1.7.10.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
WARNING: Use "yarn jar" to launch YARN applications.
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/usr/hdp/2.3.2.0-2950/spark/lib/spark-assembly-1.4.1.2.3.2.0-2950-hadoop2.7.1.2.3.2.0-2950.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/usr/hdp/2.3.2.0-2950/hadoop/lib/slf4j-log4j12-1.7.10.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation. SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
Connecting to jdbc:hive2://sandbox.hortonworks.com:10001/default
Error: Could not open client transport with JDBC Uri: jdbc:hive2://sandbox.hortonworks.com:10001/default: java.net.ConnectException: Connection refused (state=08S01,code=0)
Beeline version 1.2.1.2.3.2.0-2950 by Apache Hive
0: jdbc:hive2://sandbox.hortonworks.com:10001 (closed)>
Created 07-31-2016 12:13 AM
PEBCAK! After restarting Hive services a couple of times, and then surrounding my URI with single quotes, it appears all good.
First, made sure port 10001 is listening ...
[root@sandbox hive]# netstat -tulpna|grep 10001
tcp 0 0 0.0.0.0:10001 0.0.0.0:* LISTEN 25819/java
Then, attempted to connect with URI ...
beeline -u jdbc:hive2://sandbox.hortonworks.com:10001/default;transportMode=http;httpPath=cliservice
Finally, succeeded with URI ...
beeline -u 'jdbc:hive2://sandbox.hortonworks.com:10001/default;transportMode=http;httpPath=cliservice'
Created 07-31-2016 12:13 AM
PEBCAK! After restarting Hive services a couple of times, and then surrounding my URI with single quotes, it appears all good.
First, made sure port 10001 is listening ...
[root@sandbox hive]# netstat -tulpna|grep 10001
tcp 0 0 0.0.0.0:10001 0.0.0.0:* LISTEN 25819/java
Then, attempted to connect with URI ...
beeline -u jdbc:hive2://sandbox.hortonworks.com:10001/default;transportMode=http;httpPath=cliservice
Finally, succeeded with URI ...
beeline -u 'jdbc:hive2://sandbox.hortonworks.com:10001/default;transportMode=http;httpPath=cliservice'