Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-08-2016 03:15 PM
Guys,
When I am trying to start Spark History Server component, I see an error IllegalArgumentException not sure why it is popping up!
lease use the new key 'spark.yarn.am.waitTime' instead.
16/06/08 15:04:32 ERROR FsHistoryProvider: Exception encountered when attempting to load application log hdfs://hdfsfederation/spark-history/.a5555e556-3301-433e-44de-23311665ed
java.lang.IllegalArgumentException: Codec [a5555e556-3301-433e-44de-23311665ed] is not available. Consider setting spark.io.compression.codec=lzf
at org.apache.spark.io.CompressionCodec$$anonfun$createCodec$1.apply(CompressionCodec.scala:77)
at org.apache.spark.io.CompressionCodec$$anonfun$createCodec$1.apply(CompressionCodec.scala:77)
at scala.Option.getOrElse(Option.scala:120)
at org.apache.spark.io.CompressionCodec$.createCodec(CompressionCodec.scala:77)
I also tried setting spark.io.compression.codec = lzf ( This error didn't go) Also tried setting spark.io.compression.codec = org.apache.spark.io.LZFCompressionCodec . This also does not fix the error.
Any one faced this situation?
This is on HDP 2.4, Spark 1.6.0
Created 06-08-2016 04:38 PM
I have seen application_* files inside /spark-history directory but don't know from where you got ".a5555e556-3301-433e-44de-23311665ed. Can you check the content of this file/dir? Also what if you move this file/dir from other location and restart the spark history server?
Created 06-08-2016 04:38 PM
I have seen application_* files inside /spark-history directory but don't know from where you got ".a5555e556-3301-433e-44de-23311665ed. Can you check the content of this file/dir? Also what if you move this file/dir from other location and restart the spark history server?
Created 06-09-2016 10:32 AM
Hi @Smart Solutions Did you tried the suggested way?
Created 06-09-2016 04:33 PM
HI @Jitendra Yadav , I restarted couple of times and it worked smoothly so did not do anything else.
Thank you 🙂