Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 03-25-2014 11:13 AM - edited 09-16-2022 01:56 AM
Hi ,
CDH 4.6 and CM 4.8.2 and search 1.2 is installed in my cluster.The installation has been through parcels.I am able to start hbase,map reduce .hdfs etc .But solr service is not getting started.I am getting the below error.Dowe know the reason and how to over come it?.
Error found before invoking supervisord: User [solr] does not exist
Created 03-25-2014 01:01 PM
I'm not sure why the user wouldn't have been created, but I know you're dealing with an offline cluster so maybe something else in the parcel installation didn't work as expected. The error seems pretty clear, though, you need the "solr" user on your systems. Have you tried manually creating that user and seeing if that helps?
Created 03-25-2014 12:01 PM
Created 03-25-2014 12:34 PM
Created 03-25-2014 01:01 PM
I'm not sure why the user wouldn't have been created, but I know you're dealing with an offline cluster so maybe something else in the parcel installation didn't work as expected. The error seems pretty clear, though, you need the "solr" user on your systems. Have you tried manually creating that user and seeing if that helps?
Created 03-26-2014 03:52 PM