Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Spark-shell - Cannot run program "/etc/hadoop/conf.cloudera.yarn/topology.py"

avatar
Reader

Hi

 

I deployed CDH 5.4.8 on a 6 machine cluster (4 datanode, 1 namenode, 1 edgenode) with cloudera manager and parcels.

 

When launching `spark-shell` I get the following exception :

 

java.io.IOException: Cannot run program "/etc/hadoop/conf.cloudera.yarn/topology.py" (in directory "/home/sherloqq"): error=2, No such file or directory 

 

When searching on this error I found the following two informations :

 

- It happens with Impala & Llama, deploying Yarn Gateways on the client nodes should fix it (here, third issue)

- It's happened before and copying the `/etc/hadoop/conf.cloudera.yarn` fixes it but it's supposed to be fixed (here)

 

Adding a Yarn Gateway on the node with the Spark gateway didn't do anythig

Copying the directory to the node did fix it, however it seems to be a temporary fix

 

Is there a better fix to this issue ?

 

Thanks

 

C.

1 ACCEPTED SOLUTION

avatar
New Member
you can deploy a yarn gateway on the machine which run commond "spark-shell" .

View solution in original post

2 REPLIES 2

avatar
New Member
you can deploy a yarn gateway on the machine which run commond "spark-shell" .

avatar
Explorer

Can you please mention the steps?