Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-14-2016 08:19 PM
Hello,
I try to run:
However, with (2), I get this error:
Running Transaction Installing : rstudio-server-0.99.893-1.x86_64 1/1 groupadd: group 'rstudio-server' already exists rsession: no process killed initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused Verifying : rstudio-server-0.99.893-1.x86_64 1/1
Installed: rstudio-server.x86_64 0:0.99.893-1
Complete!
----
Then when I try (3), I get this error: [root@sandbox ~]# sudo rstudio-server verify-installation Unable to find an installation of R on the system (which R didn't return valid output); Unable to locate R binary by scanning standard locations initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused [root@sandbox ~]#
---
Looking forward to your suggestions.
Thanks,
Marcia
Created 11-15-2016 07:16 PM
It's working now...
I used the following advice:
"I found this page because I had the exact same issue! Solved it by looking in /etc/init/rstudio-server.conf Within a centos docker you can start rstudio via:
exec /usr/lib/rstudio-server/bin/rserver
That will also close your docker shell, so you might want to put it in a supervisord script, or run as daemon, or .... Maybe look at some rstudio-server dockerfiles for the different approaches usually used."
Created 11-14-2016 08:30 PM
yum install R
Created 11-14-2016 08:36 PM
I did that: yum install R .
Now I try to do:
I get the errors:
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
Created 11-14-2016 08:41 PM
@Marcia Hon you are installing Red Hat rpm packages and your command to install is yum but your error message is for Ubuntu, which OS are you using? Please make sure you're using the same packages as your OS requires.
Created 11-15-2016 12:11 AM
You mention that you installed R, but then your error point to rstudio-server. That is a different piece of software. I don't think that error is related to your R installation, but to your rstudio-server which points to R.
Created 11-14-2016 08:37 PM
How do I connect my browser to RStudio??
Created 11-14-2016 08:43 PM
Hello,
I am using the HDP 2.5 Sandbox from Hortonworks. My understanding is that it is Centos 7... How can I find out the OS?
Created 11-14-2016 08:43 PM
Hello,
I am using the HDP 2.5 Sandbox from Hortonworks. My understanding is that it is Centos 7... How can I find out the OS?
Created 11-14-2016 08:48 PM
okay, make sure you open port for the RStudio, find out what it is from their documentation and then go to your VM provider application (VirtualBox or VMWare) and open a port, usually in the port forward menu.
Created 11-14-2016 08:50 PM
[root@sandbox ~]# lsb_release -a LSB Version: :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch Distributor ID: CentOS Description: CentOS release 6.8 (Final) Release: 6.8 Codename: Final