Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-14-2016 08:19 PM
Hello,
I try to run:
However, with (2), I get this error:
Running Transaction Installing : rstudio-server-0.99.893-1.x86_64 1/1 groupadd: group 'rstudio-server' already exists rsession: no process killed initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused Verifying : rstudio-server-0.99.893-1.x86_64 1/1
Installed: rstudio-server.x86_64 0:0.99.893-1
Complete!
----
Then when I try (3), I get this error: [root@sandbox ~]# sudo rstudio-server verify-installation Unable to find an installation of R on the system (which R didn't return valid output); Unable to locate R binary by scanning standard locations initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused [root@sandbox ~]#
---
Looking forward to your suggestions.
Thanks,
Marcia
Created 11-15-2016 07:16 PM
It's working now...
I used the following advice:
"I found this page because I had the exact same issue! Solved it by looking in /etc/init/rstudio-server.conf Within a centos docker you can start rstudio via:
exec /usr/lib/rstudio-server/bin/rserver
That will also close your docker shell, so you might want to put it in a supervisord script, or run as daemon, or .... Maybe look at some rstudio-server dockerfiles for the different approaches usually used."
Created 11-15-2016 06:59 PM
Thanks for the clarification.
Still, RStudio is not working by trying your two suggestions....
Created 11-15-2016 07:16 PM
It's working now...
I used the following advice:
"I found this page because I had the exact same issue! Solved it by looking in /etc/init/rstudio-server.conf Within a centos docker you can start rstudio via:
exec /usr/lib/rstudio-server/bin/rserver
That will also close your docker shell, so you might want to put it in a supervisord script, or run as daemon, or .... Maybe look at some rstudio-server dockerfiles for the different approaches usually used."
Created 11-15-2016 07:23 PM
Very glad to know that:)
Created 11-15-2016 07:59 PM
@Marcy I'm glad you were able to resolve the problem, please use the comments section for non-solution specific dialog and only use "answer" section for solutions and anything that does not fit in comments, usually that's 600 characters or more. It is hard to follow steps to resolution if you add too many answers.
Created 03-17-2017 09:06 PM
any update here?
Running into the same issue
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused