Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-13-2018 01:14 PM
Hello,
I have a problem with SAM. After i disabled kerberos in cluster, i can't run any applications from SAM and i have next errors:
ERROR [15:43:49.990] [dw-17133 - GET /api/v1/catalog/topologies/1?detail=true&latencyTopN=3] c.h.s.s.s.CatalogResourceUtil - Unhandled exception occurs while operate with Storm
java.lang.RuntimeException: Streamline is not initialized with JAAS config. Unable to create JAAS for Storm.
at com.hortonworks.streamline.streams.storm.common.StormJaasCreator.<init>(StormJaasCreator.java:38)
at com.hortonworks.streamline.streams.actions.storm.topology.StormTopologyActionsImpl.createJaasFile(StormTopologyActionsImpl.java:489)
at com.hortonworks.streamline.streams.actions.storm.topology.StormTopologyActionsImpl.setupSecuredStormCluster(StormTopologyActionsImpl.java:200)
at com.hortonworks.streamline.streams.actions.storm.topology.StormTopologyActionsImpl.init(StormTopologyActionsImpl.java:183)
at com.hortonworks.streamline.streams.actions.container.TopologyActionsContainer.initTopologyActions(TopologyActionsContainer.java:87)
at com.hortonworks.streamline.streams.actions.container.TopologyActionsContainer.initializeInstance(TopologyActionsContainer.java:81)
at com.hortonworks.streamline.streams.actions.container.TopologyActionsContainer.initializeInstance(TopologyActionsContainer.java:38)
at com.hortonworks.streamline.streams.cluster.container.NamespaceAwareContainer.findInstance(NamespaceAwareContainer.java:54)
at com.hortonworks.streamline.streams.actions.topology.service.TopologyActionsService.getTopologyActionsInstance(TopologyActionsService.java:291)
at com.hortonworks.streamline.streams.actions.topology.service.TopologyActionsService.getRuntimeTopologyId(TopologyActionsService.java:148)
at com.hortonworks.streamline.streams.service.CatalogResourceUtil.enrichTopology(CatalogResourceUtil.java:141)
at com.hortonworks.streamline.streams.service.TopologyCatalogResource.getTopologyByIdAndVersionId(TopologyCatalogResource.java:202)
at com.hortonworks.streamline.streams.service.TopologyCatalogResource.getTopologyById(TopologyCatalogResource.java:165)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke(ResourceMethodInvocationHandlerFactory.java:81)
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher$1.run(AbstractJavaResourceMethodDispatcher.java:144)
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke(AbstractJavaResourceMethodDispatcher.java:161)
at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$ResponseOutInvoker.doDispatch(JavaResourceMethodDispatcherProvider.java:160)
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch(AbstractJavaResourceMethodDispatcher.java:99)
at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:389)
at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:347)
at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:102)
at org.glassfish.jersey.server.ServerRuntime$2.run(ServerRuntime.java:326)
at org.glassfish.jersey.internal.Errors$1.call(Errors.java:271)
at org.glassfish.jersey.internal.Errors$1.call(Errors.java:267)
at org.glassfish.jersey.internal.Errors.process(Errors.java:315)
at org.glassfish.jersey.internal.Errors.process(Errors.java:297)
at org.glassfish.jersey.internal.Errors.process(Errors.java:267)
at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:305)
at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:1154)
at org.glassfish.jersey.servlet.WebComponent.serviceImpl(WebComponent.java:473)
at org.glassfish.jersey.servlet.WebComponent.service(WebComponent.java:427)
at org.glassfish.jersey.servlet.ServletContainer.service(ServletContainer.java:388)
at org.glassfish.jersey.servlet.ServletContainer.service(ServletContainer.java:341)
at org.glassfish.jersey.servlet.ServletContainer.service(ServletContainer.java:228)
at io.dropwizard.jetty.NonblockingServletHolder.handle(NonblockingServletHolder.java:49)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1689)
at io.dropwizard.servlets.ThreadNameFilter.doFilter(ThreadNameFilter.java:34)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1676)
at io.dropwizard.jersey.filter.AllowedMethodsFilter.handle(AllowedMethodsFilter.java:50)
at io.dropwizard.jersey.filter.AllowedMethodsFilter.doFilter(AllowedMethodsFilter.java:44)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1676)
at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:581)
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1174)
at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:511)
at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1106)
at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:134)
at com.codahale.metrics.jetty9.InstrumentedHandler.handle(InstrumentedHandler.java:240)
Strom really work fine, but SAM doesn't sees it.




Created 05-22-2018 11:10 AM
Yes i did. But i don't know what is source the problem. I just completely removed storm, sam, registry, cleaned all file's association and made one thing - need to refresh "Service pool".
Just the most important - don't unkerberized cluster if you alredy kerberized it.
It may cause unexpected problems.
Created 04-03-2018 11:28 AM
We have the same problem after deleting kerberos authentication
Created 04-03-2018 11:29 AM
Do you solve it?
Created 05-22-2018 11:10 AM
Yes i did. But i don't know what is source the problem. I just completely removed storm, sam, registry, cleaned all file's association and made one thing - need to refresh "Service pool".
Just the most important - don't unkerberized cluster if you alredy kerberized it.
It may cause unexpected problems.