Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Superset crash to start on HDP 2.6.1 + HDF3

avatar
Expert Contributor

Hello,

I install hdp 2.6.1 with druid on a MySQL and then HDF (nifi+SAM) on CentOS 7.2. All the component of Druid work fine except the Superset.

When I try to start it I got the following error:

resource_management.core.exceptions.ExecutionFailed: Execution of 'source /etc/superset/conf/superset-env.sh ; /usr/hdp/current/druid-superset/bin/superset db upgrade' returned 1. /usr/hdp/2.6.1.0-129/superset/lib/python3.4/importlib/_bootstrap.py:1161: ExtDeprecationWarning: Importing flask.ext.sqlalchemy is deprecated, use flask_sqlalchemy instead.
  spec.loader.load_module(spec.name)
/usr/hdp/2.6.1.0-129/superset/lib/python3.4/importlib/_bootstrap.py:1161: ExtDeprecationWarning: Importing flask.ext.script is deprecated, use flask_script instead.
  spec.loader.load_module(spec.name)

And also:

  File "/usr/hdp/2.6.1.0-129/superset/lib/python3.4/site-packages/sqlalchemy/engine/url.py", line 60, in __init__
    self.port = int(port)
ValueError: invalid literal for int() with base 10: ''

Any idea how to make it work? Or what kind of mistake I made? 🙂

In attachment you have the full log from ambari.

Thanks,

Michelsuperset-error.txt

1 ACCEPTED SOLUTION

avatar

One of your configuration parameters for Superset is missing, it looks like it's one of the port statements.
Check that you've set the database port for MySQL and the HTTP port for Superset.

View solution in original post

2 REPLIES 2

avatar

One of your configuration parameters for Superset is missing, it looks like it's one of the port statements.
Check that you've set the database port for MySQL and the HTTP port for Superset.

avatar
New Member

I am also getting this error. I have check the config in ambari and the db port and http ports are both set.

It seems almost as if when ambari runs superset the config file in /etc/superset/conf/ isn't being used.