Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

The following service configurations have been updated and their Service Checks should be run again error when upgrade fomr 2.6.1 to 2.6.4

avatar
Rising Star

When I try to upgrade hdp version from 2.6.1 to 2.6.4, I meet the following pre-upgrade checks error :

The following service configurations have been updated and their Service Checks should be run again: HDFS, OOZIE,ZOOKEEPER,HIVE,FLUME,KAFKA,SPARK2
Failed on: HDFS, OOZIE,ZOOKEEPER,HIVE,FLUME,KAFKA,SPARK2
1 ACCEPTED SOLUTION

avatar
Master Mentor

@Junfeng Chen

You will need to run those service checks from ambari server host manually and once those service checks are successful then only you should proceed for the upgrade.

So please try this

Ambari UI --> HDFS --> "Service Actions" (drop down from right corner) --> Run Service check

Ambari UI --> OOZIE --> "Service Actions" (drop down from right corner) --> Run Service check

Ambari UI --> ZOOKEEPRR --> "Service Actions" (drop down from right corner) --> Run Service check

Ambari UI --> HIVE --> "Service Actions" (drop down from right corner) --> Run Service check

.

.

And if you see that the serivce check is failing then it means those service s are not running properly so by looking at the failed service check operation log from ambari UI you can findout why the service check failed.

Please share those logs so that we can check why the service checks are failing and then once we fix the issue and run the service checks again then we should be able to proceed with upgrade.

View solution in original post

2 REPLIES 2

avatar
Master Mentor

@Junfeng Chen

You will need to run those service checks from ambari server host manually and once those service checks are successful then only you should proceed for the upgrade.

So please try this

Ambari UI --> HDFS --> "Service Actions" (drop down from right corner) --> Run Service check

Ambari UI --> OOZIE --> "Service Actions" (drop down from right corner) --> Run Service check

Ambari UI --> ZOOKEEPRR --> "Service Actions" (drop down from right corner) --> Run Service check

Ambari UI --> HIVE --> "Service Actions" (drop down from right corner) --> Run Service check

.

.

And if you see that the serivce check is failing then it means those service s are not running properly so by looking at the failed service check operation log from ambari UI you can findout why the service check failed.

Please share those logs so that we can check why the service checks are failing and then once we fix the issue and run the service checks again then we should be able to proceed with upgrade.

avatar
Rising Star

Thanks, I have resolved it. I was regarding "Service Check" as "Pre-upgrade check".