Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-17-2015 02:42 AM
I'm running though "Securing your Hadoop Infrastructure with Apache Knox." I've installed HDP 2.3 and have been following the steps described. I can run step 6, accessing the Hadoop Cluster via WebHDFS. But step 7, accessing the Hadopp Cluster via the Apache Know Gateway fails.
curl -iku guest:guest-password -X GET 'https://localhost:8443/gateway/sandbox/webhdfs/v1/?op=LISTSTATUS'
HTTP/1.1 404 Not Found Cache-Control: must-revalidate,no-cache,no-store Content-Type: text/html;charset=ISO-8859-1 Content-Length: 1294 Server: Jetty(8.1.14.v20131031) <html> <head> <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/> <title>Error 404 Not Found</title> </head> <body> <h2>HTTP ERROR: 404</h2> <p>Problem accessing /gateway/sandbox/webhdfs/v1/. Reason: <pre> Not Found</pre></p> <hr /><i><small>Powered by Jetty://</small></i> </body> </html>
All the requisite processes seem to be running. I have no clue what to look at to get this working.
Created 12-17-2015 03:06 AM
Try this
curl -iv -k -u guest:guest-password https://sandbox:8443/gateway/default/webhdfs/v1/?op=LISTSTATUS
Created 12-17-2015 04:59 PM
Created 04-04-2018 11:19 AM
how you restarted the Knox LDAP ???
Created 12-13-2016 01:48 AM
Need to start Demo LDAP from service actions in order to test the test accounts with out LDAP integration
Created 09-28-2018 03:13 AM
I'm having the same issue!
https://knox.apache.org/books/knox-1-1-0/user-guide.html#Quick+Start
Following the tutorial step by step and the I get this:
root@hn0-securi:~/knox-1.1.0# curl -i -k -u guest:guest-password -X GET 'https://localhost:8443/gateway/sandbox/webhdfs/v1/?op=LISTSTATUS' HTTP/1.1 500 Server Error Date: Thu, 27 Sep 2018 07:45:22 GMT Set-Cookie: JSESSIONID=5qbve5zzilryrp6nfy8zztn0;Path=/gateway/sandbox;Secure;HttpOnly Set-Cookie: rememberMe=deleteMe; Path=/gateway/sandbox; Max-Age=0; Expires=Wed, 26-Sep-2018 07:45:22 GMT Content-Type: text/html; charset=ISO-8859-1 Cache-Control: must-revalidate,no-cache,no-store Content-Length: 317 Connection: close Server: Jetty(9.2.22.v20170606) <html> <head> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/> <title>Error 500 Server Error</title> </head> <body><h2>HTTP ERROR 500</h2> <p>Problem accessing /gateway/sandbox/webhdfs/v1/. Reason: <pre> Server Error</pre></p><hr><i><small>Powered by Jetty://</small></i><hr/> </body> </html>
Please help !!
Thanks