Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 08-27-2016 10:54 PM - edited 09-16-2022 03:37 AM
Hi,
I'm unable to access HDFS after enabling Kerberos authentication in my cluster. My namenode is in safe mode and is throwing out the below error when trying to execute leave safemode command.
PFB the error details:
Failed to leave Safemode: at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:230)
at com.sun.proxy.$Proxy17.setSafeMode(Unknown Source)
at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolTranslatorPB.setSafeMode(ClientNamenodeProtocolTranslatorPB.java:647)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.apache.hadoop.io.retry.RetryInvocationHandler.invokeMethod(RetryInvocationHandler.java:256)
at org.apache.hadoop.io.retry.RetryInvocationHandler.invoke(RetryInvocationHandler.java:104)
at com.sun.proxy.$Proxy18.setSafeMode(Unknown Source)
at org.apache.hadoop.hdfs.DFSClient.setSafeMode(DFSClient.java:2606)
at org.apache.hadoop.hdfs.DistributedFileSystem.setSafeMode(DistributedFileSystem.java:1132)
at org.apache.hadoop.hdfs.DistributedFileSystem.setSafeMode(DistributedFileSystem.java:1116)
at org.apache.hadoop.hdfs.tools.DFSAdmin.setSafeMode(DFSAdmin.java:571)
at org.apache.hadoop.hdfs.tools.DFSAdmin.run(DFSAdmin.java:1793)
at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
at org.apache.hadoop.hdfs.tools.DFSAdmin.main(DFSAdmin.java:1967)
16/08/28 00:34:51 WARN security.UserGroupInformation: PriviledgedActionException as:hdfs/<hostname>@SPARTA.COM (auth:KERBEROS) cause:java.io.IOException: Couldn't setup connection for hdfs/<hostname>@SPARTA.COM to <hostname>/<ip-address>:8020
safemode: Failed on local exception: java.io.IOException: Couldn't setup connection for hdfs/<hostname>@SPARTA.COM to <hostname>/<ip-address>:8020; Host Details : local host is: "<hostname>/<ip-address>"; destination host is: "<hostname>":8020;
Thanks,
Cibi
Created 09-12-2016 01:04 PM
Hi harsh,
The issue was with JCE files, i updated them in the wrong location instead of /usr/java/jdk1.7.0_25/jre/lib/security/.
Once i have updated the JCE files in the above location, now i'm able to access HDFS.
Thanks for the Help!
Regards,
Cibi
Created 09-01-2016 06:11 PM
Created 09-12-2016 01:04 PM
Hi harsh,
The issue was with JCE files, i updated them in the wrong location instead of /usr/java/jdk1.7.0_25/jre/lib/security/.
Once i have updated the JCE files in the above location, now i'm able to access HDFS.
Thanks for the Help!
Regards,
Cibi