Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-05-2017 06:15 AM
in our ambari cluster we see the following
on the first nn1
$ hdfs haadmin -checkHealth master01 Illegal argument: Unable to determine service address for namenode 'master01'
on the second namenode
$ hdfs haadmin -checkHealth master03 Illegal argument: Unable to determine service address for namenode 'master03'
what could be the problem here ?
and how to debug the command in order to verify what is the root cause ?
remark - DNS configuration on all hosts/IP are right
other example since namenode is down
[hdfs@master01 root]$ hdfs haadmin -transitionToActive --forceactive master01 Illegal argument: Unable to determine service address for namenode 'master01'
Created 12-05-2017 08:40 AM
What is the value of dfs.ha.namenodes.{ha-cluster-name} in your hdfs-site.xml
You can get the {ha-cluster-name} from fs.defaultFS from core-site.xml
Assuming fs.defaultFS is hdfs://hortonworks. hortonworks is the ha-cluster-name.
Thanks,
Aditya
Created 12-05-2017 10:53 AM
the hostname is - master01.sys56.com ( i just edit it manual because security issue) this isnt the problem
Created 12-05-2017 10:55 AM
grep dfs.namenode.rpc-address.hdfsha.nn1 /etc/hadoop/conf/hdfs-site.xml
<name>dfs.namenode.rpc-address.hdfsha.nn1</name
Created 12-05-2017 10:59 AM
do you see conflict here?
grep -A 3 dfs.ha.namenodes /etc/hadoop/conf/hdfs-site.xml
<name>dfs.ha.namenodes.hdfsha</name>
<value>nn1,nn2</value>
</property>
but:
[hdfs@master01 root]$ hdfs getconf -namenodes
master01.sys56.com master03.sys56.com
[hdfs@master01 root]$
Created 12-05-2017 12:13 PM
@Aditya , the other link ( https://community.hortonworks.com/questions/149951/how-to-force-name-node-to-be-active.html), is about force namenode to active but I just not sure if my problem here is about the same issue , so because that I opened another thread ,
second what we can do next , based on my previous question do you see any conflict ?
Created 12-05-2017 12:56 PM
@Aditya ok , so what we can do next ?