Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Unable to start NodeManager: no leveldbjni64-1.8 in java.library.path

avatar
Rising Star

Cannot bring up 2 NodeMangers, the other 19 works fine. I got this: FATAL nodemanager.NodeManager (NodeManager.java:initAndStartNodeManager(465)) - Error starting NodeManager

java.lang.UnsatisfiedLinkError: Could not load library. Reasons: [no leveldbjni64-1.8 in java.library.path, no leveldbjni-1.8 in java.library.path, no leveldbjni in java.library.path, Permission denied]

It is not caused by "chmod 777 /tmp", any clue?

1 ACCEPTED SOLUTION

avatar

Please verify that /tmp on both hosts do not have the noexec option set. You can verify this by running /bin/mount and checking the mount options. If you are able to, remount /tmp without noexec and try starting the NodeManager again. I am sure its issue with noexec on /tmp.

View solution in original post

2 REPLIES 2

avatar

Please verify that /tmp on both hosts do not have the noexec option set. You can verify this by running /bin/mount and checking the mount options. If you are able to, remount /tmp without noexec and try starting the NodeManager again. I am sure its issue with noexec on /tmp.

avatar
New Member

hello, we have security provisions that prevent us from removing the noexec from /tmp. also, this is not occuring on other nodes that have the noexec in use. is there another solution?