Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-26-2017 07:49 PM
Not able to start ambari server as non root user (ambari) after fresh installation.
[ambari@ambari ~]$ ambari-server start
Using python /usr/bin/python2.6
Starting ambari-server
Organizing resource files at /var/lib/ambari-server/resources...
Unable to check firewall status when starting without root privileges.
Please do not forget to disable or adjust firewall if needed
Server PID at: /var/run/ambari-server/ambari-server.pid
Server out at: /var/log/ambari-server/ambari-server.out
Server log at: /var/log/ambari-server/ambari-server.log
Waiting for server start....................
ERROR: Exiting with exit code -1.
REASON: Ambari Server java process died with exitcode 1. Check /var/log/ambari-server/ambari-server.out for more information.
As per log file the issue seems to be database connectivity, however, I am able to login to the database
[ambari@ambari ~]$ mysql -u ambari -p -h ambari.localdomain
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 114 Server version: 5.7.17 MySQL Community Server (GPL)
Copyright (c) 2000, 2016, Oracle and/or its affiliates. All rights reserved.
Oracle is a registered trademark of Oracle Corporation and/or its affiliates.Other names may be trademarks of their respective owners.
Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
mysql> select current_user();
+---------------------------+
| current_user() |
+---------------------------+
+---------------------------+
1 row in set (0.00 sec)
Please advise.
Created 01-26-2017 08:16 PM
Thanks for the quick response. The issue was with the password in /etc/ambari-server/conf/password.dat file.
There are couple of follow up questions:
1) While setting up ambari server it didn't allowed me to enter any special character.
Enter Database Password (bigdata):
Invalid characters in password. Use only alphanumeric or _ or - characters
Enter Database Password (bigdata):
2) After successfully starting ambari server is ambari-server.log file is filling up with errors. As log file is continuously growing up with errors I am uploading the log file.
[ambari@ambari ~]$ ambari-server start
Using python /usr/bin/python2.6
Starting ambari-server
Organizing resource files at /var/lib/ambari-server/resources...
Unable to check firewall status when starting without root privileges.
Please do not forget to disable or adjust firewall if needed
Server PID at: /var/run/ambari-server/ambari-server.pid
Server out at: /var/log/ambari-server/ambari-server.out
Server log at: /var/log/ambari-server/ambari-server.log
Waiting for server start....................
Ambari Server 'start' completed successfully.
3) Even after stopping ambari server I see that log file is filling up.
[ambari@ambari ~]$ ambari-server stop
Using python /usr/bin/python2.6
Stopping ambari-server
Ambari Server is not running
[ambari@ambari ~]$ ambari-server status
Using python /usr/bin/python2.6
Ambari-server status
Ambari Server not running.
Stale PID File at: /var/run/ambari-server/ambari-server.pid
[ambari@ambari ~]$ ps -ef|grep ambari
root 2223 1928 0 11:30 pts/1 00:00:00 su - ambari ambari 2224 2223 0 11:30 pts/1 00:00:00 -bash ambari 2735 1 0 12:02 pts/1 00:00:00 /bin/sh -c ulimit -n 10000 ; /usr/jdk64/jdk1.8.0_40/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -Dsun.zip.disableMemoryMapping=true -Xms512m -Xmx2048m -Djava.security.auth.login.config=/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/mysql-connector-java.jar:/usr/share/java/mysql-connector-java-5.1.17.jar org.apache.ambari.server.controller.AmbariServer > /var/log/ambari-server/ambari-server.out 2>&1 || echo $? > /var/run/ambari-server/ambari-server.exitcode & ambari 2736 2735 28 12:02 pts/1 00:03:30 /usr/jdk64/jdk1.8.0_40/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -Dsun.zip.disableMemoryMapping=true -Xms512m -Xmx2048m -Djava.security.auth.login.config=/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/mysql-connector-java.jar:/usr/share/java/mysql-connector-java-5.1.17.jar org.apache.ambari.server.controller.AmbariServer ambari 2899 2224 0 12:14 pts/1 00:00:00 ps -ef ambari 2900 2224 0 12:14 pts/1 00:00:00 grep ambari
Please advise.
Thank you,
Sachin A
Created 01-26-2017 08:47 PM
Do I need to rerun below command with mysql-connector-java for version 5.1.40 or just unlink the existing one and redirect to the new mysql-connector-java.jar?
ambari-server setup --jdbc-db=mysql --jdbc-driver=/usr/share/java/mysql-connector-java.jar
Please advise.
Thank you,
Sachin A
Created 01-26-2017 09:07 PM
you can re-run the command with new JDBC driver
Created 01-26-2017 09:38 PM
Thanks for your quick response. Your solution worked. Now there are no errors in ambari-server.log file.
Thank you,
Sachin A
Created 01-26-2017 09:58 PM
Thats good to hear. can you mark one of my comment/answer as correct answer please?
Created 01-26-2017 11:04 PM
looks like you have accepted question itself as answer. please select correct answer.