Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-04-2017 09:05 AM
Hi All ,
I am trying to start the HDFS using ambari . It remains stuck at following error .
safemode: Call From hostname/16.250.53.40 to hostname:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused 2017-09-04 09:00:04,064 - Retrying after 10 seconds. Reason: Execution of '/usr/hdp/current/hadoop-hdfs-namenode/bin/hdfs dfsadmin -fs hdfs://hostname:8020 -safemode get | grep 'Safe mode is OFF'' returned 1. safemode: Call From hostname/16.250.53.40 to hostname:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused safemode: Call From hostname/16.250.53.40 to hostname:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused
Created 09-04-2017 09:26 AM
Pleas emake sure that all the cluster nodes has correct FQDN configured. All the hosts are returning the correct FQDN (hostname) when we run the following command:
# hostname -f
.
Try starting the NameNode manually to see if it works ? As mentioned here: https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.2/bk_administration/content/starting_hdp_serv...
.
Created 09-04-2017 09:13 AM
Can you do the following as user root
# su - hdfs
Now as user hdfs
$ hdfs dfsadmin -safemode leave
Then restart through Ambari
Created 09-04-2017 09:23 AM
I tried that several time . It give following error too
afemode: Call From hostname/16.250.53.40 to hostnamet:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused
Created 09-04-2017 09:26 AM
Pleas emake sure that all the cluster nodes has correct FQDN configured. All the hosts are returning the correct FQDN (hostname) when we run the following command:
# hostname -f
.
Try starting the NameNode manually to see if it works ? As mentioned here: https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.2/bk_administration/content/starting_hdp_serv...
.
Created 09-04-2017 09:40 AM
It works, after stating manually as mention on this doc .
Thanks
Created 09-04-2017 09:47 AM
Did you check the connectivity from Ambari Server to Namenode service?
Created 09-04-2017 09:50 AM
Can you check the /etc/hosts on the cluster nodes and make sure the entries are like
IP:FQDN : short-name optional
And the FQDN on each host should be the exact output of
# hostname -f