Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-15-2016 07:57 AM
In the sandbox, I enable the kerborse and want to login beeline using command
!connect jdbc:hive2://localhost:10000
But got the error
Error: Could not open client transport with JDBC Uri: jdbc:hive2://localhost:10000: Peer indicated failure: Unsupported mechanism type PLAIN (state=08S01,code=0)
And here's the log in hiveserver2.log
2016-03-15 07:52:31,067 ERROR [HiveServer2-Handler-Pool: Thread-45]: server.TThreadPoolServer (TThreadPoolServer.java:run(296)) - Error occurred during processing of message.
java.lang.RuntimeException: org.apache.thrift.transport.TTransportException: Unsupported mechanism type PLAIN
at org.apache.thrift.transport.TSaslServerTransport$Factory.getTransport(TSaslServerTransport.java:219)
at org.apache.hadoop.hive.thrift.HadoopThriftAuthBridge$Server$TUGIAssumingTransportFactory$1.run(HadoopThriftAuthBridge.java:739)
at org.apache.hadoop.hive.thrift.HadoopThriftAuthBridge$Server$TUGIAssumingTransportFactory$1.run(HadoopThriftAuthBridge.java:736)
at java.security.AccessController.doPrivileged(Native Method)
at javax.security.auth.Subject.doAs(Subject.java:356)
at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1637)
at org.apache.hadoop.hive.thrift.HadoopThriftAuthBridge$Server$TUGIAssumingTransportFactory.getTransport(HadoopThriftAuthBridge.java:736)
Created 03-15-2016 08:21 AM
If you have enabled kerberos your connection string should look as follows:
!connect jdbc:hive2://<hiveserver host>:<port>/default;principal=hive/_HOST@<REALM>
Created 03-15-2016 08:21 AM
If you have enabled kerberos your connection string should look as follows:
!connect jdbc:hive2://<hiveserver host>:<port>/default;principal=hive/_HOST@<REALM>
Created 03-15-2016 10:25 AM
Thanks, it works.