Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-10-2016 09:49 AM
Unable to validate location with path /apps/falcon/primaryCluster/staging for cluster:primaryCluster due to transcient failures :
I have this error when i try to submit a cluster to Apache falcon. I believed it is due to permissions but I follow the step to switch the ownership to falcon user :
drwxr-xr-x - falcon hdfs 0 2016-02-10 10:17 /apps/falcon/backupCluster
drwxrwxrwx - falcon hdfs 0 2016-02-10 10:16 /apps/falcon/backupCluster/staging
drwxr-xr-x - falcon hdfs 0 2016-02-10 10:17 /apps/falcon/backupCluster/working
drwxr-xr-x - falcon hdfs 0 2016-02-10 10:16 /apps/falcon/primaryCluster
drwxrwxrwx - falcon hdfs 0 2016-02-10 10:16 /apps/falcon/primaryCluster/staging
drwxr-xr-x - falcon hdfs 0 2016-02-10 10:16 /apps/falcon/primaryCluster/working
Here is my xml :
<cluster xmlns='uri:falcon:cluster:0.1' name='primaryCluster' description='thie is primary cluster' colo='primaryColo'> <tags>primaryKey=primaryValue</tags> <interfaces> <interface type='readonly' endpoint='hftp://dl-master:50070' version='2.2.0'> </interface> <interface type='write' endpoint='hdfs://dl-master:8020' version='2.2.0'> </interface> <interface type='execute' endpoint='dl-master:8050' version='2.2.0'> </interface> <interface type='workflow' endpoint='http://dl-master:11000/oozie/' version='4.0.0'> </interface> <interface type='messaging' endpoint='tcp://10.0.0.5:61616?daemon=true' version='5.4.6'> </interface> </interfaces> <locations> <location name='staging' path='/apps/falcon/primaryCluster/staging'> </location> <location name='temp' path='/tmp'> </location> <location name='working' path='/apps/falcon/primaryCluster/working'> </location> </locations> <ACL owner='ambari-qa' group='users' permission='0x755'/> <properties> <property name='brokerImplClass' value='org.apache.activemq.ActiveMQConnectionFactory'> </property> </properties> </cluster>
I am using FalconWebUI to submit the cluster.
Created 02-10-2016 09:51 AM
Created 02-10-2016 09:51 AM
Created 02-10-2016 10:16 AM
But if I submit the cluster with the WebUI, I should be under falcon user. Is there a way to submit with WebUI ?
Created 02-10-2016 10:26 AM
Created 02-10-2016 10:40 AM
I think it works, I faced no error. Thank you !
Is there a way to confirm that the cluster was created ? EDIT: I find it when i create a new mirror, Thank you for the Help
Created 02-10-2016 10:42 AM
@Arthur GREVIN You should have the confirmation screen ...http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0/bk_data_governance/content/section_creating_...
Please do accept the answer to close the thread.
Created 02-10-2016 10:43 AM
@Arthur GREVIN You nailed it !!! 🙂