Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-01-2016 10:33 PM
My first step was to create an ORC table on Hive with the same schema as the one imported on hdp :
CREATE TABLE IF NOT EXISTS orcemployees( emp_no int, birth_date date, first_name string, last_name string, gender string, hire_date date) STORED AS ORC;
My second step was to copy the data from employees into orcemployees:
insert into table orcemployees select * from employees;
The problem is when I execute select * from orcemployees; the schema is displayed and not the associated data.
Created 02-02-2016 03:13 PM
your error says you don't have permissions for admin user on that folder. You need to
sudo -u hdfs hdfs dfs -chown -R admin:hdfs /tmp/task/employees
OR
sudo -u hdfs hdfs dfs -chmod -R 777 /tmp/task/employees
Created 02-02-2016 05:20 PM
@Artem Ervits -- How can I set primary key and reference foreign keys while creating a table / extrenal table in hive?
I'm getting the following error:
Created 02-02-2016 05:22 PM
@keerthana gajarajakumar please open a new thread as this is a new question.
Created 02-02-2016 05:27 PM
ok @Artem Ervits -- i just posted a question for this.
Created 02-12-2016 07:41 AM
This tutorial walks you through the process of creating Hive ORC table from existing Hive table using Ambari Hive User View: