Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-28-2017 05:33 PM
Hello,
I configured ambari admin UI on 8443 SSL port.
My hadoop cluster have 3 nodes, i configured kerberose on it.
But when i am enabling HTTPS on yarn,hdfs,mapreduce.
It stop coomunicating with ambari UI, ambari server still communicating and fetching information from old http port while i configured it for HTTPS.
Is there any document on which i can find configuration of SSL in ambari server ?
Created 03-28-2017 05:48 PM
Have you followed the similar steps mentioned: https://community.hortonworks.com/articles/52876/enable-https-for-yarn-and-mapreduce2.html
Do you see any error in the logs of those components? (or they are running fine)
Do you see the communication on the https port?
# openssl s_client -connect ${COMPONENTS}:${SECURE_PORT} -showcerts < /dev/null.
Have you restarted ambari server.
Browser cache is cleared (or tested form other browser)
Created 03-28-2017 05:48 PM
Have you followed the similar steps mentioned: https://community.hortonworks.com/articles/52876/enable-https-for-yarn-and-mapreduce2.html
Do you see any error in the logs of those components? (or they are running fine)
Do you see the communication on the https port?
# openssl s_client -connect ${COMPONENTS}:${SECURE_PORT} -showcerts < /dev/null.
Have you restarted ambari server.
Browser cache is cleared (or tested form other browser)
Created 04-04-2017 09:18 AM
Thanks.
Its working.
But while i updated everything.
Yarn still shows error in ambari for old port.
while new services are running on new SSL port.
anything need to change on ambari side.