Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 12-28-2015 03:43 PM - edited 09-16-2022 02:54 AM
In http://hortonworks.com/hadoop-tutorial/hello-world... it mentions that you could run the queries via the shell. I am using an Azure sandbox 2.3.2 and I can login using my username/password. However, when I "su hive" it will not accept any of the passwords I could think to try ("hive", "admin", "hadoop").
Created 12-28-2015 06:23 PM
@Peter Lasne All Service accounts i.e. hive, hdfs, mapred etc. are kind of password-less with auto generated and auto changed hash passwords i.e. managed accounts. You can login to these users from a sudo user account or as root user by doing "su - hive" or "sudo su - hive" and so on based on root or sudo user account.
On other hand, to bring up hive shell, you don't need to login as hive as @Deepesh said. You can bring up hive shell by typing hive at terminal prompt.
Created 12-28-2015 05:10 PM
You should be able to bring up hive shell as the login user (without su as hive) by typing hive at the terminal prompt.
Created 12-28-2015 06:23 PM
@Peter Lasne All Service accounts i.e. hive, hdfs, mapred etc. are kind of password-less with auto generated and auto changed hash passwords i.e. managed accounts. You can login to these users from a sudo user account or as root user by doing "su - hive" or "sudo su - hive" and so on based on root or sudo user account.
On other hand, to bring up hive shell, you don't need to login as hive as @Deepesh said. You can bring up hive shell by typing hive at terminal prompt.
Created 12-28-2015 07:37 PM
Thanks. "sudo su - hive" worked. However, I cannot just use my account because it throws a permissions error. If you happened to see my other threads I am getting some permissions errors there too, but all I did was install the sandbox, shouldn't that already be configured with the appropriate permissions?
Logging initialized using configuration in file:/etc/hive/2.3.2.0-2950/0/hive-log4j.properties
Exception in thread "main" java.lang.RuntimeException: org.apache.hadoop.security.AccessControlException: Permission denied: user=plasne, access=WRITE, inode="/user/plasne":hdfs:hdfs:drwxr-xr-x
Created 12-29-2015 03:14 PM
In case this helps with the tutorial, I believe the permission error went away after I created a /user directory for my account in HDFS. I was using the Azure sandbox 2.3.2 so my username was something I keyed in when creating the VM.
Created 12-28-2016 05:50 AM
I think your path "/user/plasne" in HDFS dont have write permission.
Kindly try to give write permission for respective path, suppose you are in Ubuntu
"hadoop fs -chmod g+w /user/plasne" without quotes in terminal
then start your hive