Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-03-2017 03:26 PM
Hi.
I am doing a fresh install of HDP2.5.
I am trying to do:
sudo ambari-server setup
but I got this error:
File "/usr/lib/python2.6/site-packages/ambari_server/serverClassPath.py", line 28, in <module>
from resource_management.core.shell import quote_bash_args
ImportError: No module named resource_management.core.shellI fixed this by copying in the quote_bash_args routine from here and removing the import.
Now I get another error, again because the core and/or shell module is missing:
File "/usr/sbin/ambari-server.py", line 39, in <module>
from ambari_server.serverSetup import reset, setup, setup_jce_policy
File "/usr/lib/python2.6/site-packages/ambari_server/serverSetup.py", line 31, in <module>
from ambari_commons.firewall import Firewall
File "/usr/lib/python2.6/site-packages/ambari_commons/firewall.py", line 25, in <module>
from resource_management.core import shell
ImportError: No module named resource_management.coreWhere can I get the latest core and shell modules from?
Created 05-03-2017 05:13 PM
@ed day I'm guessing your ambari-server setup is borked. Please reinstall ambari server and agent. When you remove the packages, make sure to clean /var/lib/ambari-server /usr/lib/ambari-server /usr/lib/python2.6/site-packages/ambari* etc.
Created 05-03-2017 05:13 PM
@ed day I'm guessing your ambari-server setup is borked. Please reinstall ambari server and agent. When you remove the packages, make sure to clean /var/lib/ambari-server /usr/lib/ambari-server /usr/lib/python2.6/site-packages/ambari* etc.
Created 05-07-2017 07:48 AM
It was, as you say, borked and it was /usr/lib/python2.6/site-packages that was the problem. Many thanks!
Created 10-25-2017 05:19 PM
@Artem Ervits I cleaned up /var/lib/ambari-server, /usr/lib/python2.6/site-packages/ambari* and did a clean insall. But each time I do the install it says creating site-packages/resource_management : File exists. So even after a clean install the setup gives me the same error. How do I get around with this?