Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-17-2016 09:29 AM
Are there any extra settings needed for using YARN REST API in a kerberos enabled environment?
Trying to create a new application using below curl call gives HTTP/1.1 500 Internal Server Error. The same cluster without kerberos works fine.
Command used:
curl --negotiate -ikv -u: -X PUT 'http://<yarn host>l:8088/ws/v1/cluster/apps/new-application'
Created 02-17-2016 09:49 AM
OK. need to use POST instead of PUT in the curl call and it works fine.
curl --negotiate -ikv -u: -X POST 'http://<yarn host>:8088/ws/v1/cluster/apps/new-application'
Created 02-17-2016 09:44 AM
To add more, the GET operation works fine for the kerberos cluster.
Created 02-17-2016 09:48 AM
Internal server error? Can you look into the yarn logs and see what he complains about? You said it works fine without kerberos but perhaps you don't have the rights to kick off an application or something.
/var/log/hadoop-yarn/yarn/yarn-yarn-nodemanager-sandbox.hortonworks.com.log
Created 02-17-2016 09:44 AM
Perhaps just a simple thing, can you try it with the -u : instead of -u: Below is my prefix I use for a webhdfs command.
curl --negotiate -u : -i -s -X PUT
Created 02-17-2016 09:49 AM
OK. need to use POST instead of PUT in the curl call and it works fine.
curl --negotiate -ikv -u: -X POST 'http://<yarn host>:8088/ws/v1/cluster/apps/new-application'