Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-06-2017 09:12 AM
I m trying to install hdp 2.5 in my cluster , I lanched the wizard Ambari 2.5 and everythings was okey untill Ambari gets to installing services and in the last part of installation I got this error of permissions with zeppelin notebook:
raise ExecutionFailed(err_msg, code, out, err) resource_management.core.exceptions.ExecutionFailed: Execution of 'echo spark_version:1.6 detected for spark_home: /usr/hdp/current/spark-client >> /var/log/zeppelin/zeppelin-setup.log' returned 1. su: warning: cannot change directory to /home/zeppelin: Permission denied -bash: /home/zeppelin/.bash_profile: Permission denied -bash: /var/log/zeppelin/zeppelin-setup.log: Permission denied
I tried to create this directories /var/log/zeppelin and associte permission to user zeppelin but I still get the same error.
what should I do??
Created 12-08-2017 01:07 PM
solution in two lines of code:
sudo chown -R zeppelin:zeppelin /var/log/zeppelin/ sudo chown -R zeppelin:zeppelin /home/zeppelin
Created 12-06-2017 12:00 PM
Are you running this as root user?
Also, see - https://community.hortonworks.com/questions/44451/zeppelin-service-not-starting-via-hdp-24-ambari.ht...
Created 12-08-2017 01:07 PM
solution in two lines of code:
sudo chown -R zeppelin:zeppelin /var/log/zeppelin/ sudo chown -R zeppelin:zeppelin /home/zeppelin