Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-29-2016 04:31 AM
I use ambari 2.2.1.0 and use nonroot user running ther server and the agent.
Install hdp 2.3.4.0-3485 is ok,when I try to start the service such as hdfs ,it was failed with errors,the logs content is blow...
stderr: /var/lib/ambari-agent/data/errors-69.txtTraceback (most recent call last):
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-START/scripts/hook.py", line 39, in <module>
BeforeStartHook().execute()
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 219, in execute
method(env)
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-START/scripts/hook.py", line 28, in hook
import params
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-START/scripts/params.py", line 141, in <module>
ambari_db_rca_password = config['hostLevelParams']['ambari_db_rca_password'][0]
TypeError: 'int' object is unsubscriptable
stdout: /var/lib/ambari-agent/data/output-69.txt
2016-03-29 12:21:52,902 - The hadoop conf dir /usr/hdp/current/hadoop-client/conf exists, will call conf-select on it for version 2.3.4.0-3485
2016-03-29 12:21:52,902 - Checking if need to create versioned conf dir /etc/hadoop/2.3.4.0-3485/0
2016-03-29 12:21:52,903 - call['conf-select create-conf-dir --package hadoop --stack-version 2.3.4.0-3485 --conf-version 0'] {'logoutput': False, 'sudo': True, 'quiet': False, 'stderr': -1}
2016-03-29 12:21:52,952 - call returned (1, '/etc/hadoop/2.3.4.0-3485/0 exist already', '')
2016-03-29 12:21:52,952 - checked_call['conf-select set-conf-dir --package hadoop --stack-version 2.3.4.0-3485 --conf-version 0'] {'logoutput': False, 'sudo': True, 'quiet': False}
2016-03-29 12:21:52,996 - checked_call returned (0, '/usr/hdp/2.3.4.0-3485/hadoop/conf -> /etc/hadoop/2.3.4.0-3485/0')
2016-03-29 12:21:52,997 - Ensuring that hadoop has the correct symlink structure
2016-03-29 12:21:52,997 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
I had google it for times but no result about.
Created 04-07-2016 03:17 AM
I have reslove the problem.
as I posrt above ,I print the data struct
'ambari_db_rca_password':'123456',
I think it is a sting ,but when I print its type,it is a int type.
So I change the password to 'ambari',it is a sting,then every thing is goto OK!!!
Is still a problem of ambari
Created 03-29-2016 02:57 PM
@jeff
I once think it was the upgrade cause this problem,so I use clean virtual machine to try thi s,but problem is still the same。
My OS is centos 6.6 64 bit in virtual box,and I use my local ambari repo ,repo name is ambari 2.2.1 upgrade。When I try to install,I use yum install,an show that 2.2.1 is installed,is this the problem?
Created 04-07-2016 03:17 AM
I have reslove the problem.
as I posrt above ,I print the data struct
'ambari_db_rca_password':'123456',
I think it is a sting ,but when I print its type,it is a int type.
So I change the password to 'ambari',it is a sting,then every thing is goto OK!!!
Is still a problem of ambari
Created 04-07-2016 03:45 AM
Please accept best answer or post your comment as answer