Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-06-2017 02:50 PM
Ambari 2.5.1 hadoop 2.5
running check from ambari it fails
resource_management.core.exceptions.ExecutionFailed: Execution of '/var/lib/ambari-agent/tmp/templetonSmoke.sh server.domain.com ambari-qa 50111 idtest.ambari-qa.1499352141.17.pig /etc/security/keytabs/smokeuser.headless.keytab true /usr/bin/kinit [email protected] /var/lib/ambari-agent/tmp' returned 1. Templeton Smoke Test (ddl cmd): Failed. : {"error":"java.lang.reflect.UndeclaredThrowableException"}http_code <500>
Created 07-06-2017 03:14 PM
ROOT CAUSE
I hope hadoop.proxyuser.HTTP.hosts was not set to the host where webhcat was running.
RESOLUTION
1. Identify and note the node where WebHCat Server runs
2. Using Ambari HDFS-Configs, check if hadoop.proxyuser.HTTP.hosts is defined in core-site section or change as below
hadoop.proxyuser.HTTP.hosts=* hadoop.proxyuser.HTTP.groups=*
3. If exists, update the parameter to include the WebHCat node name
4. If not, add the parameter and include WebHCat node name to the same
5. Restart all the services that needs restart including Hive
6. Run Hive service check again
Hope this helps you.
Created 07-06-2017 03:14 PM
ROOT CAUSE
I hope hadoop.proxyuser.HTTP.hosts was not set to the host where webhcat was running.
RESOLUTION
1. Identify and note the node where WebHCat Server runs
2. Using Ambari HDFS-Configs, check if hadoop.proxyuser.HTTP.hosts is defined in core-site section or change as below
hadoop.proxyuser.HTTP.hosts=* hadoop.proxyuser.HTTP.groups=*
3. If exists, update the parameter to include the WebHCat node name
4. If not, add the parameter and include WebHCat node name to the same
5. Restart all the services that needs restart including Hive
6. Run Hive service check again
Hope this helps you.
Created 07-06-2017 05:39 PM
Yeah. added into "Custom webhcat-site" under hive conf in ambari
webhcat.proxyuser.HTTP.groups=*
webhcat.proxyuser.HTTP.hosts=*