Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

error when yum install ambari-server

avatar
Expert Contributor

I have 5 servers, 1 nn, 4 dn and all has no public IP or internet access. all my servers are local network, no internet access. so I have downloaded ambari.repo and upload to /etc/yum.repos.d on my server.

when yum install ambari-server, I got error:

Loaded plugins: changelog, fastestmirror, fs-snapshot, product-id,
              : rhui-lb, security, subscription-manager, verify
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.0.0/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'public-repo-1.hortonworks.com'"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-2.0.0. Please verify its path and try again

I think it try to reach to internet, but I dont have that access in my system. so what I can work around.to have additional downloads?

1 ACCEPTED SOLUTION

avatar
Master Mentor

@Robin Dong

It won't work ..You have to setup local repo because you servers are not connected to the internet.

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_Installing_HDP_AMB/content/_using_a_local...

View solution in original post

4 REPLIES 4

avatar
Master Mentor

@Robin Dong

It won't work ..You have to setup local repo because you servers are not connected to the internet.

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_Installing_HDP_AMB/content/_using_a_local...

avatar
Master Mentor

@Robin Dong It's really doc and please follow it step by step. Most of the production installs works on local repo.

avatar
Master Mentor

@Robin Dong has this been resolved? Can you provide a solution or accept the best answer?

avatar
New Member

This error comes when yum tries to connect the repository (over the internet connection) to install the Ambari server. There are 2 ways:

1- Enable the internet connection.

2- Prepare the local inventory and change the URL to redirect to local repository instead repository over the internet. For this point , in Hortonworks document provides the steps and you can follow the same.

Other option is to download tar files of ambari installation ,place in some directory, go to that directory and start the http server using python and then update that url in yum repo file of ambari installation.