Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-15-2016 07:48 PM
I created a cluster using cloudbreak and the EDW-ANALYTICS 2.5 tech preview template. The cluster is up and running and when I look at the Hive properties I can see the Interactive query settings enabled and an llap queue.
I am not able to set the llap configuration option in beeline. Beeline says the hive.llap.execution.mode variable does not exist:
jdbc:hive2://localhost:10000> set hive.llap.execution.mode=all;
Error: Error while processing statement: hive configuration hive.llap.execution.mode does not exists. (state=42000,code=1)
The example demos I see on the web use their variable and the documentation references it:
How do I start a hive query using LLAP?
Created 08-15-2016 08:32 PM
In order to use LLAP, you should connect to Hive2 HiveServer2. However, based on the jdbc url, it seems you are connecting to Hive1 HiveServer2. That's probably why you get the error, 'hive.llap.execution.mode variable does not exist'.
Hive2 HiveServer2 port is typically 10500.
You should figure out the Hive2 HiveServer2 host (whether it is localhost), get the correct jdbc url and connect to Hive2 HiveServer2 with the jdbc url.
Created 08-15-2016 08:32 PM
In order to use LLAP, you should connect to Hive2 HiveServer2. However, based on the jdbc url, it seems you are connecting to Hive1 HiveServer2. That's probably why you get the error, 'hive.llap.execution.mode variable does not exist'.
Hive2 HiveServer2 port is typically 10500.
You should figure out the Hive2 HiveServer2 host (whether it is localhost), get the correct jdbc url and connect to Hive2 HiveServer2 with the jdbc url.
Created 08-15-2016 09:13 PM
@Takahiko Saito Where should I look in Ambari to find the Hive2 HiveServer2 port?
Created 08-15-2016 09:30 PM
I found the port by going to Ambari > Hive configs tab under Advanced hive-interactive-site HiveServer2 Port and it was set to the default 10500.
Created 09-10-2016 06:54 PM
I would also add that the HiveServer2 Interactive service and HiveServer2 may be deployed to different hosts.