Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-23-2017 01:36 PM
Hi,
I am using HDP 2.5 on azure HDinsight cluster. Yesterday it cluster was working fine and I was able to put data from local to hdfs from one client node. But since morning I am getting error while putting data to hdfs.
Error:- hdfs dfs -put abc /shaz -put: Self-suppression not permitted Usage: hadoop fs [generic options] -put [-f] [-p] [-l] <localsrc> ... <dst>
Thanks in Advance...!!!!!!!!!
Created 08-28-2017 07:16 AM
Hi issue is resolved.
Issue was with azure cloud. There azure storage jar was updated.
Updated jar: hadoop/lib/azure-storage-4.2.0.jar
The supported version of the JAR is 2.2.0.
I have reverted the version to old. And it works.
Created 08-23-2017 02:55 PM
You'll likely need to go through the whole error message, the underlying root cause will be in the error/exception message. Typically, you can see that when the data node storage is full, or when network communication was severed.
Created 08-24-2017 04:50 AM
@Sonu sahi
I have checked all possibilities like disk size, hostname, network. There is no issue with disk, network.
Created 08-24-2017 03:07 PM
You'll need to check the entire error message, typically the root cause is somewhere near the bottom
Created 08-28-2017 07:16 AM
Hi issue is resolved.
Issue was with azure cloud. There azure storage jar was updated.
Updated jar: hadoop/lib/azure-storage-4.2.0.jar
The supported version of the JAR is 2.2.0.
I have reverted the version to old. And it works.