Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-15-2016 10:04 PM
I am getting the following error , even though JAVA is installed on every node.
Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py", line 35, in <module>
BeforeAnyHook().execute()
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute
method(env)
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py", line 32, in hook
setup_java()
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/shared_initialization.py", line 181, in setup_java
raise Fail(format("Unable to access {java_exec}. Confirm you have copied jdk to this host."))
resource_management.core.exceptions.Fail: Unable to access /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.111.x86_64/bin/java. Confirm you have copied jdk to this host.
Error: Error: Unable to run the custom hook script ['/usr/bin/python', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py', 'ANY', '/var/lib/ambari-agent/data/command-2222.json', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY', '/var/lib/ambari-agent/data/structured-out-2222.json', 'INFO', '/var/lib/ambari-agent/tmp']
Created 11-16-2016 02:51 AM
can you confirm java is installed here
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.111.x86_64/bin/java
Created 11-16-2016 02:51 AM
can you confirm java is installed here
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.111.x86_64/bin/java
Created 11-16-2016 05:44 PM
yes you were right , some how the java was upgraded to a new release 121 , I fixed the issue by creating a symbolic link as follows :
[root@hadoop1 jvm]# pwd /usr/lib/jvm [root@hadoop1 jvm]# ln -s /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.121.x86_64 /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.111.x86_64