Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-28-2016 05:53 PM
I am able to run hive query through its shell but not able to run it by putting it into file. It gives me permission denied.
I tried to run it through hdfs user but still getting same error.
Created 05-28-2016 09:20 PM
Below are the valid examples for running hive queries
$HIVE_HOME/bin/hive -e 'select a.col from tab1 a'
$HIVE_HOME/bin/hive -e 'select a.col from tab1 a' --hiveconf hive.exec.scratchdir=/home/my/hive_scratch --hiveconf mapred.reduce.tasks=32
$HIVE_HOME/bin/hive -S -e 'select a.col from tab1 a' > a.txt
$HIVE_HOME/bin/hive -f /home/my/hive-script.sql
$HIVE_HOME/bin/hive -f hdfs://<namenode>:<port>/hive-script.sql $HIVE_HOME/bin/hive -f s3://mys3bucket/s3-script.sql
$HIVE_HOME/bin/hive -i /home/my/hive-init.sql
Created 05-28-2016 05:54 PM
Please share the steps you performed along with error message.
Created 05-28-2016 09:20 PM
Below are the valid examples for running hive queries
$HIVE_HOME/bin/hive -e 'select a.col from tab1 a'
$HIVE_HOME/bin/hive -e 'select a.col from tab1 a' --hiveconf hive.exec.scratchdir=/home/my/hive_scratch --hiveconf mapred.reduce.tasks=32
$HIVE_HOME/bin/hive -S -e 'select a.col from tab1 a' > a.txt
$HIVE_HOME/bin/hive -f /home/my/hive-script.sql
$HIVE_HOME/bin/hive -f hdfs://<namenode>:<port>/hive-script.sql $HIVE_HOME/bin/hive -f s3://mys3bucket/s3-script.sql
$HIVE_HOME/bin/hive -i /home/my/hive-init.sql
Created 05-30-2016 08:55 AM
Thanks kuldeep i am able to run hive queries by putting in file now.