Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-21-2016 09:06 PM
Hello,
I am using HDP 2.5 and knox 0.9. After adding :
<service>
<role>OOZIEUI</role>
<url>http://{{oozie_server_host}}:{{oozie_server_port}}/oozie</url>
</service>
to the advanced topology and restarting servicies, the oozie url is coming up like the attached:
screen-shot-2016-09-21-at-50902-pm.png
I can access the URL but all the css and other stuff do not get loaded. In the knox log i see the below. Other Hadoop UI's like YARN are working okay
2016-09-21 21:02:43,231 INFO hadoop.gateway (AclsAuthorizationFilter.java:doFilter(85)) - Access Granted: true 2016-09-21 21:02:58,456 WARN hadoop.gateway (GatewayFilter.java:doFilter(162)) - Failed to match path /ext-2.2/resources/css/ext-all.css 2016-09-21 21:02:58,486 WARN hadoop.gateway (GatewayFilter.java:doFilter(162)) - Failed to match path /ext-2.2/resources/css/xtheme-default.css 2016-09-21 21:02:58,518 WARN hadoop.gateway (GatewayFilter.java:doFilter(162)) - Failed to match path /oozie-console.css 2016-09-21 21:02:58,548 WARN hadoop.gateway (GatewayFilter.java:doFilter(162)) - Failed to match path /console/sla/css/jquery.dataTables.css
Created 09-22-2016 03:49 AM
https://issues.apache.org/jira/browse/KNOX-628
temp fix is to add a trailing / at the end. This is similar to an open jira for ambari. ex:
https://<knox_gateway>:8443/gateway/default/oozie/
the last "/" is required.
Created 09-22-2016 03:49 AM
https://issues.apache.org/jira/browse/KNOX-628
temp fix is to add a trailing / at the end. This is similar to an open jira for ambari. ex:
https://<knox_gateway>:8443/gateway/default/oozie/
the last "/" is required.
Created 03-01-2019 07:09 AM
Thank you for your help.
Created 08-22-2017 06:53 AM
Even I m getting the same error and I added trailing at the end " https://<knox_gateway>:8443/gateway/default/oozie/" still I am facing the same issue.How to resolve it ?