Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-03-2017 01:39 AM - edited 08-18-2019 01:32 AM
I'm running a kerberized HDP cluster and am unable to access the Workflow Manager view because the Oozie check is failing.
Looking at the Workflow Manager view logs (/var/log/ambari-server/wfmanager-view/wfmanager-view.log), I can see that a null pointer exception is thrown after the oozie admin URL is attempted to be accessed:
02 Apr 2017 18:33:41,326 INFO [main] [ ] OozieProxyImpersonator:111 - OozieProxyImpersonator initialized for instance: WORKFLOW_MANAGER_VIEW 02 Apr 2017 18:35:13,927 INFO [ambari-client-thread-85] [WORKFLOW_MANAGER 1.0.0 WORKFLOW_MANAGER_VIEW] OozieDelegate:149 - Proxy request for url: [GET] http://hdp1.woolford.io:11000/oozie/v1/admin/configuration 02 Apr 2017 18:35:14,163 ERROR [ambari-client-thread-85] [WORKFLOW_MANAGER 1.0.0 WORKFLOW_MANAGER_VIEW] OozieProxyImpersonator:484 - Error in GET proxy java.lang.RuntimeException: java.lang.NullPointerException
I'm able to access the Oozie web UI and the admin configuration URL (http://hdp1.woolford.io:11000/oozie/v1/admin/configuration) in a browser, and so it appears that Oozie is working, e.g.
I'm not sure if it's relevant to this issue, but the Oozie user can impersonate any user from any host (from core-site.xml):
<property> <name>hadoop.proxyuser.oozie.hosts</name> <value>*</value> </property> <property> <name>hadoop.proxyuser.oozie.groups</name> <value>*</value> </property>
Can you see what I'm doing wrong? Is there any other relevant information I should add to this question?
Created 04-03-2017 06:55 PM
@Alex Woolford, Did you configure Kerberos for WFM? http://docs.hortonworks.com/HDPDocuments/Ambari-2.5.0.3/bk_ambari-views/content/wfm-kerberos-setup.h...
Also, ensure you completed other configuration requirements: http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.0/bk_workflow-management/content/config_wfm_vi...
Created 04-03-2017 06:55 PM
@Alex Woolford, Did you configure Kerberos for WFM? http://docs.hortonworks.com/HDPDocuments/Ambari-2.5.0.3/bk_ambari-views/content/wfm-kerberos-setup.h...
Also, ensure you completed other configuration requirements: http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.0/bk_workflow-management/content/config_wfm_vi...
Created 04-04-2017 03:24 AM
Thanks so much, @Beverley Andalora. I somehow missed this in the docs. 🙂
Per the link you sent, I added the following properties to Oozie-site and it's working perfectly:
oozie.service.ProxyUserService.proxyuser.[ambari-server-cl1].groups=* oozie.service.ProxyUserService.proxyuser.[ambari-server-cl1].hosts=*
Created 09-04-2018 12:20 PM
org.apache.ambari.view.commons.exceptions.ServiceFormattedException at org.apache.ambari.view.commons.hdfs.UserService.homeDir(UserService.java:7
User home directory not found...
Cluster is kerberized...please help