Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-29-2016 02:41 PM
Hi ,
Ambari-server installation fails with following error:
[root@VORA1 ~]# yum install ambari-server
Loaded plugins: product-id, rhnplugin, search-disabled-repos, security, subscription-manager This system is receiving updates from RHN Classic or RHN Satellite. Setting up Install Process http://10.78.1.240/hdp/HDP/centos6/2.x/updates/2.3.4.0/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host" Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: HDP-2.3.4.0. Please verify its path and try again
Please suggest.
Thanks
Created 09-29-2016 07:18 PM
If you are using local repo then dont point it to the public repo and make sure yoour satelitte server can serve at that URL
baseurl=http://10.78.1.240/AMBARI-2.2.1.0/centos6/2.2.1.0-161/ gpgcheck=0 enabled=0 priority=1
yum clean all yum install ambari-server
That should work
Created 09-29-2016 02:45 PM
@jyoti gupta are you using custom repositories? Please check if you are able to access the host and files
Created 09-29-2016 03:33 PM
@pankaj singhwe are using local repositories. Able to access host too. Following is the content of ambari.repo:
name=ambari-2.2.1.0 - Updates
baseurl=http://10.78.1.240/AMBARI-2.2.1.0/centos6/2.2.1.0-161/
gpgcheck=1 gpgkey=http://public-repo-1.hortonworks.com/ambari/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins enabled=1
priority=1
Created 09-29-2016 05:32 PM
rememberd a similar question asked - The link may be of help
Created 09-29-2016 08:33 PM
the link talks about proxy setting. we don't have proxy
Created 09-29-2016 07:18 PM
If you are using local repo then dont point it to the public repo and make sure yoour satelitte server can serve at that URL
baseurl=http://10.78.1.240/AMBARI-2.2.1.0/centos6/2.2.1.0-161/ gpgcheck=0 enabled=0 priority=1
yum clean all yum install ambari-server
That should work
Created 09-30-2016 12:36 PM
Issue got Resolved. Satellite server was not properly installed. Reconfiguring satellite server, starting httpd service and configuring ambari.repo as per your suggestion worked. Thanks @Geoffrey Shelton Okot 🙂
Created 09-30-2016 06:11 AM
Looks like there is no metadata in your repository. Can you try running
sudo createrepo .
in your folder pointed by baseurl.