Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Atlas uses Solr to store Lineage meta information and uses Zookeeper for co-ordination and store/maintain configuration.
Due to heavy load on Zookeeper on larger cluster we need to increase timeout for ZK session for some services from default.
One such config is for Ambari infra (Solr) zookeeper time on Atlas side.
ERROR: java.util.concurrent.TimeoutException: Could not connect to ZooKeeper vb-hortonwork.com:2181/infra-solr within 15000 ms java.util.concurrent.TimeoutException: Could not connect to ZooKeeper vb-hortonwork.com:2181/infra-solr within 15000 ms
RESOLUTION: We can increase the session timeout from default 15000 by adding below properties in custom application-properties in atlas -> config