Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Created on 05-16-201811:20 PM - edited 09-16-202201:43 AM
In order to debug pairing DLM, you'll need the following pre-req:
1) Root access to the DPS VM
Problem statement - have you received an error when pairing a cluster?
Follow these step-by-step instructions to access the DLM log, to gain granular log information that will help you debug:
1) Run the "sudo docker ps" command to gain the container id for "dlm-app":
In the image above, the container id for "dlm-app" is "83d879e9a45e".
2) Once you receive the container id, you can run the following command "sudo docker exec -it 83d879e9a45e /bin/tailf /usr/dlm-app/logs/application.log"
This will give you insight into the DPS-DLM application, in the example above you'll see "ERROR". The error log will post once you click "pair" in the DLM UI. Using the information from the log, you'll be able to troubleshoot your issue.