Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Expert Contributor

In Beeline, the command-line options such as sslTrustStore, trustStorePassword, showDbInPromp etc are case sensitive.

 

For example, below is a working connection string from a test bed: 

beeline -u "jdbc:hive2://host-A-fqdn:21051/default;principal=impala/[email protected];ssl=true;sslTrustStore=/opt/cloudera/security/truststore.jks" 

 In the above example, the common mistakes are principal mentioned as Principal and sslTrustStore mentioned as ssltruststore.

 

Here, if the case sensitivity is not followed, Beeline silently ignores the command line options and drops them: 

//Sample string

beeline -u "jdbc:hive2://host-A-fqdn:21051/default;Principal=impala/[email protected];ssl=true;ssltruststore=/opt/cloudera/security/truststore.jks"

If you use the above connection string, at first, you will encounter a Kerberos issue as the property "principal" will be dropped and the actual Kerberos authentication will fail. If you fix the Kerberos issue, then you would encounter SSL related error as the ssltruststore needs to be written as "sslTrustStore". 

 

You can find the other command-line options under Beeline Command Options. 

3,348 Views
Version history
Last update:
‎05-03-2021 10:58 PM
Updated by: