Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 02-22-2017 04:21 AM
I have tried copying data between non-kerberized cluster to kerberized cluster using Snapshot diff, but it was failing with following error in HDP 2.5.3
Currently distcp only supports hdfs:// RPC protocol for snapshot based diff copy. If you use webhdfs either in source or target you will encouter this error.
Command:
$hadoop distcp -diff s1 s2 -update webhdfs://nonsecure_cluster:50070/source hdfs://secure_cluster:8020/target
Error:
Created on 04-18-2017 06:34 PM
Are you able to update with the target with snapshot difference?
hadoop distcp -diff s1 s2 -update hdfs://secure_cluster:8020/source hdfs://secure_cluster:8020/target
though it is syntactically correct, I don't see its working, I see the error as below.
17/04/18 14:29:53 ERROR tools.DistCp: Invalid arguments: java.lang.IllegalArgumentException: Diff is valid only with update and delete options at org.apache.hadoop.tools.DistCpOptions.validate(DistCpOptions.java:568) at org.apache.hadoop.tools.DistCpOptions.setUseDiff(DistCpOptions.java:284) at org.apache.hadoop.tools.OptionsParser.parse(OptionsParser.java:223) at org.apache.hadoop.tools.DistCp.run(DistCp.java:115) at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:76) at org.apache.hadoop.tools.DistCp.main(DistCp.java:430)
Invalid arguments: Diff is valid only with update and delete options usage: distcp OPTIONS [source_path...] <target_path>
Created on 07-11-2017 03:11 PM
Hello @Rajesh,
Following the lovely request of a customer here, there is a HWKs tasks to support it with HDP3.0.
If there is some way to backport it, I will try to update this thread.
With kind regards
Created on 09-09-2017 12:41 PM
Thanks for the update! I ran into this myself when designing a Python HDFS snapshot manager for two of our clusters.
Created on 07-10-2018 03:44 PM
Does anyone found a solution about this issue ?
Thanks