Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Expert Contributor

When upgrading to HDP 2.5 or later with Falcon, you might encounter the following error when starting the ActiveMQ server:


ERROR - [main:] ~ Failed to start ActiveMQ JMS Message Broker. Reason: java.lang.NegativeArraySizeException (BrokerService:528)

You might also encounter this error if downgrading Falcon from HDP 2.5 to an earlier release.

If you encounter this error, delete the ActiveMQ history and then restart Falcon. If you want to retain the history, be sure to back up the ActiveMQ history prior to deleting it.


cd <ACTIVEMQ_DATA_DIR>
rm -rf ./localhost
cd /usr/hdp/current/falcon-server

su -l <FALCON_USER>



./bin/falcon-stop

./bin/falcon-start
2,341 Views
0 Kudos
Comments
avatar

Maybe:

su -l <FALCON_USER>

cd /usr/hdp/current/falcon-server


avatar

> If you want to retain the history

After taking a backup, how could I restore?

Version history
Last update:
‎03-16-2017 12:40 AM
Updated by:
Contributors