Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Super Collaborator

Short Description:

This article will help to renew kerberos ticket with Falcon.

 

Article

It has been seen that Falcon server fails to perform operations after kerberos credentials expire and following exception occur.

 

 

Caused by: org.apache.hadoop.security.authentication.client.AuthenticationException: GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)

 

 

 

To solve this issue, we must set following parameter in Falcon startup.properties through ambari-ui to revalidate kerberos credentials. Value for this properties is in seconds.

  1. Stop Falcon server
  2. Set parameter : *.falcon.service.authentication.token.validity=<value in seconds>
  3. Start Falcon server

Note: This article is for version greater than HDP-2.5.* .

1,086 Views
0 Kudos
Version history
Last update:
‎09-12-2019 05:45 PM
Updated by:
Contributors