Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
03-14-2017
02:09 PM
- edited on
04-21-2026
05:24 AM
by
GrazittiAPI
yum update -y mkfs -t ext4 /dev/xvdb mkfs -t ext4 /dev/xvdc mkfs -t ext4 /dev/xvdd mkdir /mnt/nifi_content mkdir /mnt/nifi_flowfile mkdir /mnt/nifi_prov mount /dev/xvdb /mnt/nifi_content/ mount /dev/xvdc /mnt/nifi_flowfile/ mount /dev/xvdd /mnt/nifi_prov/ echo "/dev/xvdb /mnt/nifi_content ext4 errors=remount-ro 0 1" >> /etc/fstab echo "/dev/xvdc /mnt/nifi_flowfile ext4 errors=remount-ro 0 1" >> /etc/fstab echo "/dev/xvdd /mnt/nifi_prov ext4 errors=remount-ro 0 1" >> /etc/fstab
export hdf_ambari_mpack_url=http://public-repo-1.hortonworks.com/HDF/centos7/2.x/updates/2.1.2.0/tars/hdf_ambari_mp/hdf-ambari-mpack-2.1.2.0-10.tar.gz yum install -y git python-argparse git clone https://github.com/seanorama/ambari-bootstrap.git export install_ambari_server=true ~/ambari-bootstrap/ambari-bootstrap.sh ambari-server install-mpack --mpack=${hdf_ambari_mpack_url} --purge --verbose #enter 'yes' to purge at prompt ambari-server restart
export ambari_server= <FQDN of host where ambari-server will be installed>; export install_ambari_server=false curl -sSL https://raw.githubusercontent.com/seanorama/ambari-bootstrap/master/ambari-bootstrap.sh | sudo -E sh ;
In this article we have deployed sets of AWS EC2 instances for HDF clusters, prepared and deployed the necessary packages, and set the necessary configuration parameters to allow NiFi SiteToSite to operate behind the AWS EC2 NAT implementation.
In the next article I will outline how to build the Dataflow for generating a small files performance test, and pushing that data efficiently via SiteToSite.