Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Created on 11-19-201601:41 PM - edited 08-17-201907:48 AM
PROBLEM STATEMENT: Customer deleted hdfs repository from ranger ui. Tried re-enabling plugin but the repository was getting created. Reinstalled ranger, but still no luck.
There was alert saying - "Ranger Admin Password check"
Text is: This alert is used to ensure that the Ranger Admin password in Ambari is correct.
Response is: User:amb_ranger_admin credentials on Ambari UI are not in sync with Ranger
Doing a test and changing ranger_admin_password to admin in Ambari. Configs->Advanced
Restarting Ranger, not prompted but doing so anyway.
Also changed local password on ranger admin host:
[root@ip-172-53-51-18 admin]# passwd amb_ranger_admin
Changing password for user amb_ranger_admin.
New password:
Retype new password:
passwd: all authentication tokens updated successfully.
Did restart of HDFS, but now HDFS was not coming up.
ERROR:
Ranger admin log error:
2016-08-26 11:06:22,917 [http-bio-6080-exec-4] INFO org.apache.ranger.common.RESTErrorUtil (RESTErrorUtil.java:311) - Operation error. response=VXResponse={org.apache.ranger.view.VXResponse@7097c06cstatusCode={1} msgDesc={User is not allowed to update service-def, only Admin can create/update/delete Services} messageList={[VXMessage={org.apache.ranger.view.VXMessage@4718e9efname={OPER_NO_PERMISSION} rbKey={xa.error.oper_no_permission} message={User doesn't have permission to perform this operation} objectId={null} fieldName={null} }]} }
From Ambari startup stderr box:
2016-08-26 11:06:20,803 - Error creating repository. Http status code - 400.
{"statusCode":1,"msgDesc":"User is not allowed to update service-def, only Admin can create/update/delete Services","messageList":[{"name":"OPER_NO_PERMISSION","rbKey":"xa.error.oper_no_permission","message":"User doesn't have permission to perform this operation"}]}
2016-08-26 11:07:08,595 - Error creating repository. Http status code - 400.
{"statusCode":1,"msgDesc":"User is not allowed to update service-def, only Admin can create/update/delete Services","messageList":[{"name":"OPER_NO_PERMISSION","rbKey":"xa.error.oper_no_permission","message":"User doesn't have permission to perform this operation"}]}
2016-08-26 11:07:56,368 - Error creating repository. Http status code - 400.
{"statusCode":1,"msgDesc":"User is not allowed to update service-def, only Admin can create/update/delete Services","messageList":[{"name":"OPER_NO_PERMISSION","rbKey":"xa.error.oper_no_permission","message":"User doesn't have permission to perform this operation"}]}
2016-08-26 11:29:02,647 [http-bio-6080-exec-2] INFO org.apache.ranger.common.RESTErrorUtil (RESTErrorUtil.java:311) - Operation error. response=VXResponse={org.apache.ranger.view.VXResponse@6189b1d4statusCode={1} msgDesc={User is not allowed to update service-def, only Admin can create/update/delete Services} messageList={[VXMessage={org.apache.ranger.view.VXMessage@6291937cname={OPER_NO_PERMISSION} rbKey={xa.error.oper_no_permission} message={User doesn't have permission to perform this operation} objectId={null} fieldName={null} }]} }
ROOT CAUSE: Role for 'amb_ranger_admin' user was not set to admin in ranger UI.
RESOLUTION: Changing the role of 'amb_ranger_admin' user to admin from ranger UI resolved the issue.