Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Contributor

Environment: HDP on AWS EC2 instances.

Problem: When trying to execute a hive ddl script, we get the error file does not exist. Upon checking the file exists and also has the read write privileges.

Root Cause: The directory where the script exists does not have read write permission to the user.

Solution: Open the directory permission to include the necessary read, write permission to the user.

Following is a screenshot that shows the problem and solution used to fix it.

82384-directorypermissionhive.png

3,202 Views
Comments
avatar
Contributor

This could be the potential solution for this "hive script does not exist" question as well:

https://community.hortonworks.com/questions/25588/hive-script-error-script-does-not-exists-error.htm...

Version history
Last update:
‎08-17-2019 06:52 AM
Updated by:
Contributors