Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Rising Star

PROBLEM:

In hive, on oracle metastore following error is observed for table creation,

java.sql.SQLException: ORA-01461: can bind a LONG value only for insert into a LONG column

ROOT CAUSE:

Issue looks to be due to large number of columns in this table.

RESOLUTION:

Currently hive will we store column stats in a table while we store the accuracy in another table (table properites). The best way is to store both the column stats and its accuracy in the same table. This involves modification of schema.
As a workaround we can change the column type to CLOB.

1,999 Views
Comments
avatar
New Member

Oracle LONG columns are a nasty biz. They work with practically no other SQL or PL/SQL data types. Depending on the actual version of the DBMS, VARCHAR2 values can get treated as LONG and cause errors like this.

Version history
Last update:
‎02-14-2020 01:31 AM
Updated by: