Community Articles
Find and share helpful community-sourced technical articles
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.
Labels (1)

Problem Statement:

When you try to execute GET call using ambari api to list/GET services, it usually gives error as shown below -

# curl -u admin:admin -H "X-Requested-By: ambari" -X GET  http://<AMBARI_SERVER_HOST>:8080/api/v1/clusters/<cluster_name>/services/

curl: (1) Protocol  http not supported or disabled in libcurl

OR

# curl -u admin:admin -H "X-Requested-By: ambari" -X GET “http://node1.example.com:8080/api/v1/clusters/HDP_TEST/services/“

curl: (1) Protocol “http not supported or disabled in libcurl

Solution:

  1. It’s a tipical curl_php error, but, the error response is not very, ehmmmm easy to deduce. It’s simple, surely there is an extra space before ‘http’, so check the CURLOPT_URL declaration, and search for this space, and then, delete it!!!!
  2. Make sure the syntax of double quotes is correct. This also leads to the error.
819 Views
Don't have an account?
Coming from Hortonworks? Activate your account here
Version history
Revision #:
1 of 1
Last update:
‎05-27-2016 01:20 PM
Updated by:
 
Contributors
Top Kudoed Authors