Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar
Rising Star

Issue:

In a heavily utilized kafka cluster AMS will keep on crashing with error

"ERROR org.apache.hadoop.hbase.client.AsyncProcess: Cannot get replica 0 location for {"totalColumns":5,"row":"kafka.server.FetcherLagMetrics."

Solution:

1. Run the following command to gather the amount of metrics being collected:

curl http://<Ambari-metrics-collector-host>:6188/ws/v1/timeline/metrics/metadata

2. From Ambari UI -> Kafka -> Configs -> Fliter

search for: "external.kafka.metrics.exclude.prefix"

3. Add the following at the end:

kafka.log.Log

4. Restart Kafka.

This will exclude additional metrics from getting captured and will increase the stability of the AMS.

2,596 Views
Comments
avatar
Expert Contributor

We have two filter options external.kafka.metrics.exclude.prefix and external.kafka.metrics.include.prefix.

https://github.com/hortonworks/ambari/blob/AMBARI-2.7.0-maint/ambari-metrics/ambari-metrics-kafka-si...

 

Version history
Last update:
‎12-31-2016 11:00 PM
Updated by:
Contributors